1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

meld shows output in unreadable alphabet (Japanese/Chinese?) Ubuntu

Discussion in 'Ubuntu Forums' started by UBUNTUOOP, Jan 12, 2017.

  1. UBUNTUOOP

    UBUNTUOOP Active Member

    Messages:
    19,453
    Likes Received:
    0
    Trophy Points:
    36
    meld shows output in unreadable alphabet (Japanese/Chinese?) on Ubuntu ?

     
     
  2. Avatar

    Advertisement

  3. BiepD

    BiepD Guest Guest Post

    I have the same problem. Two versions of the same file, one showed in complex characters. After copying the readable side into the unreadable side and reopening, both had become unreadable. There are even switches in reading direction in the file.

    Here is line 1:
    ‣敔搠敯㩮䘠汩啥楴獬挮灯⁹敧牢極敫潶牯栠瑥攠湥潶摵杩敷⁧潫楰狫湥瘠湡戠獥慴摮湥‮娠敩映

    Corresponding to a real text starting this way:
    # Te doen: FileUtils.copy gebruiken voor het eenvoudigweg kopiëren van bestanden. Zie fxri.
    require 'fileutils'
    begin
     
  4. BiepD

    BiepD Guest Guest Post

    I found this solution on the web:

    File encoding is not correctly detected.
    In my case this is due to meld's "detect-encodings" settings.

    Check with:
    $ gsettings get org.gnome.meld detect-encodings
    ['utf8']
    Only utf8 is detected.

    To workaround this issue add 'latin1' or whatever encoding your file has:
    $ gsettings set org.gnome.meld detect-encodings "['utf8','latin1']"
     
  5. Avatar

    Advertisement

  6. Avatar

    Advertisement

Share This Page